Is It Ruby 1.9: Report and Track How Compatible Ruby Libraries Are With 1.9

Tháng Hai 7, 2009

Source: http://www.rubyinside.com/is-it-ruby-19-report-and-track-how-compatible-ruby-libraries-are-with-19-1489.html

Ruby 1.9.1 was released last week but due to the significant changes between the 1.8 and 1.9 versions of MRI, not all libraries and gems work with it. The trouble is.. which do and which don’t? My advice last week was to just start playing and not to switch anything serious across until you could guarantee all of your preferred libraries worked.

Is It Ruby 1.9 – developed by Rails host Brightbox – helps with the process of tracking gem compatibility with Ruby 1.9. It’s a place for the Ruby community to both report and track compatibility for all public gems. For example, I can see that so far 3 people have reported success with Hpricot and 2 have reported failures. If you visit the Hpricot specific page, you can read the reports users have given to find out how to get it working on 1.9.1. The same applies for every other gem..

This is a great resource and if you’re savvy enough to play with 1.9.1 and to try installing gems, get on to Is It Ruby 1.9 now and report your own results. A lot of gems have no reported failures or successes yet, so there’s a lot of opportunity to help the community out. Alternatively, if you just want to get help and monitor progress, you can also subscribe to RSS feeds for the gems you’re most interested in.

Gửi phản hồi

Mời bạn điền thông tin vào ô dưới đây hoặc kích vào một biểu tượng để đăng nhập:

WordPress.com Logo

Bạn đang bình luận bằng tài khoản WordPress.com Log Out / Thay đổi )

Twitter picture

Bạn đang bình luận bằng tài khoản Twitter Log Out / Thay đổi )

Facebook photo

Bạn đang bình luận bằng tài khoản Facebook Log Out / Thay đổi )

Google+ photo

Bạn đang bình luận bằng tài khoản Google+ Log Out / Thay đổi )

Connecting to %s

%d bloggers like this: